<!DOCTYPE html> <html lang="en-US" xmlns:og="http://opengraphprotocol.org/schema/" xmlns:fb="http://www.facebook.com/2008/fbml"> <head><link rel="dns-prefetch" href="//ajax.googleapis.com">
<link rel="dns-prefetch" href="//www.google.com">
<link rel="dns-prefetch" href="//fonts.googleapis.com">
<link rel="preload" href="https://www.theyukonreview.com/wp-content/cache/borlabs_cache/1/js/6746357faff282db9f27c20335a419f0a8ffa2ee_https.js" as="script">
<link rel="preload" href="https://www.theyukonreview.com/wp-content/cache/borlabs_cache/1/css/8aa33534da9ced34336d161e2a9286123956155a_https.css" as="style">
<link rel="stylesheet" href="https://www.theyukonreview.com/wp-content/cache/borlabs_cache/1/css/8aa33534da9ced34336d161e2a9286123956155a_https.css" type="text/css" media="all"><link href="https://fonts.googleapis.com/css?family=Oswald%3A400" rel="stylesheet"> <meta charset="UTF-8" /> <meta name="viewport" content="width=device-width, initial-scale=1.0" /> <meta http-equiv="X-UA-Compatible" content="IE=edge" /> <link rel="profile" href="https://gmpg.org/xfn/11" /> <link rel="pingback" href="https://www.theyukonreview.com/xmlrpc.php" />   <!--[if lt IE 9]> <script src="https://www.theyukonreview.com/wp-content/themes/bb-theme/js/html5shiv.js"></script> <script src="https://www.theyukonreview.com/wp-content/themes/bb-theme/js/respond.min.js"></script> <![endif]--> <title>County ADA says pending homicides high &#8211; Yukon Review</title>  <link rel='dns-prefetch' href='//ajax.googleapis.com' /> <link rel='dns-prefetch' href='//www.google.com' /> <link rel="alternate" type="application/rss+xml" title="Yukon Review &raquo; Feed" href="https://www.theyukonreview.com/feed/" /> <link rel="alternate" type="application/rss+xml" title="Yukon Review &raquo; Comments Feed" href="https://www.theyukonreview.com/comments/feed/" /> <link rel="alternate" type="application/rss+xml" title="Yukon Review &raquo; County ADA says pending homicides high Comments Feed" href="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/feed/" /> <meta property="og:title" content="County ADA says pending homicides high"/><meta property="og:type" content="article"/><meta property="og:url" content="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/"/><meta property="og:site_name" content="Yukon Review"/><meta property="og:image" content="https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2.jpg"/>                      <style id='wp-polls-inline-css' type='text/css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.theyukonreview.com/wp-content/plugins/webads-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>                                                   <link rel="https://api.w.org/" href="https://www.theyukonreview.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.theyukonreview.com/wp-json/wp/v2/posts/307974" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.theyukonreview.com/xmlrpc.php?rsd" /> <link rel='prev' title='Training held for veterans, service dogs' href='https://www.theyukonreview.com/2021/03/18/training-held-for-veterans-service-dogs/' /> <link rel="canonical" href="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/" /> <link rel='shortlink' href='https://www.theyukonreview.com/?p=307974' /> <link rel="alternate" type="application/json+oembed" href="https://www.theyukonreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyukonreview.com%2F2021%2F03%2F22%2Fcounty-ada-says-pending-homicides-high%2F" /> <link rel="alternate" type="text/xml+oembed" href="https://www.theyukonreview.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.theyukonreview.com%2F2021%2F03%2F22%2Fcounty-ada-says-pending-homicides-high%2F&#038;format=xml" />  <style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px 0px 0px 0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>  <link rel="shortcut icon" href="https://www.theyukonreview.com/wp-content/uploads/2021/03/favicon-16x16-1.png"/>  <script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js?ver=1.12.4' id='jquery-js'></script><script type='text/javascript' src='https://www.google.com/recaptcha/api.js?ver=cef01ca959904e16df765d8c4d7a0ad2' id='recaptcha-scripts-js'></script><script type="text/javascript" src="https://www.theyukonreview.com/wp-content/cache/borlabs_cache/1/js/6746357faff282db9f27c20335a419f0a8ffa2ee_https.js"></script></head> <body class="post-template-default single single-post postid-307974 single-format-standard ecwd-theme-parent-bb-theme ecwd-theme-child-bb-theme-child fl-preset-color01 fl-fixed-width" itemscope="itemscope" itemtype="http://schema.org/WebPage"> <div> <div class="fl-page-bar"> <div class="fl-page-bar-container container"> <div class="fl-page-bar-row row"> <div class="col-md-8 hidden-sm text-left clearfix"> <div class="breakingNews" id="bn7"> <div class="bn-title"><h2>Breaking News</h2><span></span></div> <ul> <li><a href="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/">County ADA says pending homicides high</a></li> <li><a href="https://www.theyukonreview.com/2021/03/18/training-held-for-veterans-service-dogs/">Training held for veterans, service dogs</a></li> <li><a href="https://www.theyukonreview.com/2021/03/18/canadian-county-camp-hope-to-serve-children-teens-exposed-to-domestic-violence/">Canadian County Camp HOPE to serve children, teens exposed to domestic violence</a></li> <li><a href="https://www.theyukonreview.com/2021/03/11/307961/">Oklahoman details life without traditional shelter</a></li> <li><a href="https://www.theyukonreview.com/2021/03/10/mhs-to-return-to-classrooms-fulltime/">MHS to return to classrooms fulltime</a></li> <li><a href="https://www.theyukonreview.com/2021/03/10/mustang-officers-undergo-mental-health-training/">Mustang officers undergo mental health training</a></li> <li><a href="https://www.theyukonreview.com/2021/03/08/oklahoman-details-life-without-traditional-shelter/">Oklahoman details life without traditional shelter</a></li> <li><a href="https://www.theyukonreview.com/2021/03/08/shelter-needed-by-many-but-not-wanted-by-some/">Shelter needed by many, but not wanted by some</a></li> <li><a href="https://www.theyukonreview.com/2021/03/08/local-nonprofits-officials-say-homelessness-on-the-rise/">Local nonprofits, officials say homelessness on the rise</a></li> <li><a href="https://www.theyukonreview.com/2021/03/08/homeless-shelter-not-in-citys-plans/">Homeless shelter not in city’s plans</a></li> </ul> <div class="bn-navi"> <span></span> <span></span> </div> </div>  <div class="fl-page-bar-text fl-page-bar-text-1"></div></div> <div class="col-md-4 col-sm-12 text-right clearfix"><ul id="menu-top-bar-menu" class="fl-page-bar-nav nav navbar-nav menu"><li id="menu-item-8660" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-8660"><a href="#">Contact Us</a> <ul class="sub-menu"> <li id="menu-item-284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-284"><a href="https://www.theyukonreview.com/contact-us/">Contact Yukon Review</a></li> <li id="menu-item-8661" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8661"><a href="https://www.theyukonreview.com/contact-mustang-news/">Contact Mustang News</a></li> </ul> </li> <li id="menu-item-7896" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7896"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-285" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-285"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff">Yukon Review E-Edition</a></li> <li id="menu-item-7897" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7897"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24">Mustang News E-Edition</a></li> </ul> </li> <li id="menu-item-7895" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7895"><a href="#">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-286" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-286"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff&#038;view=subscribe">Yukon Review</a></li> <li id="menu-item-7898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7898"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24&#038;view=subscribe">Mustang News</a></li> </ul> </li> <li id="menu-item-7894" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7894"><a href="#">Archives</a> <ul class="sub-menu"> <li id="menu-item-287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-287"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff&#038;view=archives">Yukon Review Archives</a></li> <li id="menu-item-7904" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7904"><a href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24&#038;view=archives">Mustang News Archives</a></li> </ul> </li> </ul><div class="fl-social-icons"><a href="/cdn-cgi/l/email-protection#afcacbc6dbc0ddefdbc7cad6dac4c0c1ddcad9c6cad881ccc0c2" class="fl-icon fl-icon-color-mono fl-icon-email fl-icon-email-regular"></a></div></div> </div> </div> </div></div> <div class="fl-page"> <header class="fl-page-header fl-page-header-primary fl-page-nav-bottom fl-page-nav-toggle-button" itemscope="itemscope" itemtype="http://schema.org/WPHeader"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-8 col-sm-8"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="http://schema.org/Organization"> <a href="https://www.theyukonreview.com" itemprop="url"><img class="fl-logo-img" itemscope itemtype="http://schema.org/ImageObject" src="https://www.theyukonreview.com/wp-content/uploads/2016/06/HNN-Logo-1-1.png" data-retina="" alt="Yukon Review" /><meta itemprop="name" content="Yukon Review" /></a> </div> </div> <div class="col-md-4 col-sm-4"> <div class="fl-page-header-content"> <div id="webads_weather_widget-2" class="widget widget_webads_weather_widget pull-right">  <div id="webads-weather-73085" class="widget widget-webads-weather"> <a id="webads-weather-73085-link" href="https://www.theyukonreview.com"> <div class="awe-mini"> <div> <div class="col visual"> <span id="webads-weather-73085-temperature" class="temperature"></span> <i id="webads-weather-73085-image" class="weather-forecast-icon" style="background-size:contain"></i> </div> <div class="col info"> <span id="webads-weather-73085-location" class="location"></span> <span id="webads-weather-73085-conditions" class="forecast"></span> </div> </div> </div> </a> </div>  </div><div id="search-2" class="widget widget_search pull-right"><form method="get" role="search" action="https://www.theyukonreview.com" title="Type and press Enter to search."> <input type="text" class="fl-search-input" name="s" class="form-control" value="Search" onfocus="if (this.value == 'Search') { this.value = ''; }" onblur="if (this.value == '') this.value='Search';"> </form></div> </div> </div> </div> </div> </div> <div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav navbar navbar-default" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span>Menu</span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-main-menu" class="nav navbar-nav menu"><li id="menu-item-1076" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-has-children menu-item-1076"><a href="https://www.theyukonreview.com/">Home</a> <ul class="sub-menu"> <li id="menu-item-8743" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8743"><a href="https://www.theyukonreview.com/yukon-review/">Yukon Review Homepage</a></li> <li id="menu-item-8742" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8742"><a href="https://www.theyukonreview.com/mustang-news/">Mustang News Homepage</a></li> </ul> </li> <li id="menu-item-7890" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7890"><a href="#">E-Editions</a> <ul class="sub-menu"> <li id="menu-item-296" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-296"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff">Yukon Review E-Edition</a></li> <li id="menu-item-7891" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7891"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24">Mustang News E-Edition</a></li> </ul> </li> <li id="menu-item-7888" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7888"><a href="#">Subscribe</a> <ul class="sub-menu"> <li id="menu-item-297" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-297"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff&#038;view=subscribe">Yukon Review</a></li> <li id="menu-item-7889" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7889"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24&#038;view=subscribe">Mustang News</a></li> </ul> </li> <li id="menu-item-303910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-303910"><a href="https://www.theyukonreview.com/category/sports/">Yukon Sports</a></li> <li id="menu-item-32917" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32917"><a href="https://www.theyukonreview.com/mustang-sports/">Mustang Sports</a></li> <li id="menu-item-293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-293"><a href="https://www.theyukonreview.com/photos/">Photos</a></li> <li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://www.theyukonreview.com/crossword/">Crossword</a></li> <li id="menu-item-4243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-4243"><a href="#">Regional News</a> <ul class="sub-menu"> <li id="menu-item-6414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6414"><a href="https://www.theyukonreview.com/oklahoma-news/">Oklahoma News</a></li> <li id="menu-item-6413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6413"><a href="https://www.theyukonreview.com/oklahoma-city-news/">Oklahoma City News</a></li> <li id="menu-item-6412" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6412"><a href="https://www.theyukonreview.com/ou-news/">University of Oklahoma News</a></li> <li id="menu-item-6411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6411"><a href="https://www.theyukonreview.com/oklahoma-state-news/">Oklahoma State University News</a></li> </ul> </li> </ul> </div> </nav> </div> </div> </header> <div class="fl-page-content" itemprop="mainContentOfPage"> <div class="webads-userbar-wrapper" style="display: none;"><span class="webads-userbar"><span class="webads-userbar-name"></span><span class="fl-sep"> | </span><a href="https://www.theyukonreview.com/wp-admin/admin-post.php?action=webads_logout&webads_logout_nonce=DS9URN7DtQcxre6U"><span>logout</span></a></span></div>  <div class="container"> <div class="row"> <div class="fl-content fl-content-left col-md-9"> <article class="fl-post post-307974 post type-post status-publish format-standard has-post-thumbnail hentry category-breaking-news category-canadian-county category-news category-yukon-review-breaking-news" id="fl-post-307974" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> County ADA says pending homicides high </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person">By <a href="https://www.theyukonreview.com/author/haley/" itemprop="url"><span itemprop="name">Haley Humphrey</span></a></span><span class="fl-sep"> | </span><span class="fl-post-date" itemprop="datePublished" datetime="2021-03-22">March 22, 2021</span><span class="fl-sep"> | </span><span class="fl-comments-popup-link"><a href="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/#respond">0 <i class="fa fa-comment"></i></a></span></div><meta itemprop="image" content="https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2.jpg"><meta itemprop="interactionCount" content="UserComments:0"> </header> <div class="fl-post-content clearfix" itemprop="text"> <p>&nbsp;</p> <p>The 19 pending homicides throughout Canadian County are the most Assistant District Attorney Eric Epplin has worked in his three and a half years with the county.<br /> While Epplin said the 19 are very sad, he noted there are no pending intimate partner homicides in the county. There were also no intimate partner homicides in 2020 nor 2019.<br /> More than 90% of women murdered by men are killed by someone they know, according to the Violence Policy Center, a national research nonprofit.<br /> Oklahoma ranks third in the nation for the homicide rate among females murdered by males.<br /> However, there are two pending child abuse homicides in the county.</p> <div id="attachment_307975" style="width: 283px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-307975" loading="lazy" class="size-medium wp-image-307975" src="https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2-273x300.jpg" alt="" width="273" height="300" srcset="https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2-273x300.jpg 273w, https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2-932x1024.jpg 932w, https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2-768x844.jpg 768w, https://www.theyukonreview.com/wp-content/uploads/2021/03/CC-courthouse-2.jpg 1092w" sizes="(max-width: 273px) 100vw, 273px" /><p id="caption-attachment-307975" class="wp-caption-text">A Lady of Justice statue stands inside the second floor of the Canadian County Courthouse. She holds balance scales in her left hand to symbolize impartiality and obligation of the law to weigh the evidence presented to the court. In her right hand, she holds a sword to represent enforcement and respect, meaning justice stands by its ruling. Over her eyes is a blindfold, which signifies the law’s objectivity. Some meanings say the blindfold doesn’t allow outside factors, like politics, wealth or fame to influence its decisions. Photo / Haley Humphrey</p></div> <p>March 16, 2018<br /> Ronnie Miller III, 34, was charged with two counts of first-degree murder Sept. 24, 2018.<br /> Oklahoma City police responded at about 1:51 a.m. March 16, 2018 to an injury incident in Yukon. When officers arrived on scene, first responders were treating Cody Early, 23, of Bethany and Shaun Ruddle, 39, of Midwest City.<br /> The two, who had been shot, were “slumped over” in the front driver and passenger seats, a report read. Both males were pronounced dead at the scene.</p> <p>Aug. 5, 2018<br /> Brianne Risher, 41, of Del City was charged with first-degree manslaughter; leaving the scene of a fatal accident; transporting an open container; and possession of paraphernalia Aug. 24, 2018. Risher collided with a vehicle in Canadian County Aug. 5, 2018.<br /> The collision happened at about 12:47 a.m. on State Highway 152 and south Gregory Road. A traffic collision report said Risher’s vehicle was stopped westbound on State Highway 152.<br /> A witness was standing beside the driver’s window of her vehicle. Meanwhile, a motorcycle, which was driven by Kelis Hart, 40, of Mustang, was stopped, facing west in front of Risher’s Nissan Altima.<br /> Pedestrian Dustie Hart, 39, of Mustang stood in front of the car on its passenger side. Suddenly, the Altima accelerated forward, its front left colliding with the motorcycle’s rear, the report said.<br /> The front right of Risher’s car also hit Dustie Hart. Risher left the scene but returned later.<br /> Dustie Hart was transported to University of Oklahoma Medical Center.</p> <p>Sept. 14, 2018<br /> Zachary Huber, 28, was charged with first-degree murder Sept. 24, 2018.<br /> El Reno officers responded at about 6:50 p.m. Sept. 14, 2018 to a person, who was shot at Ruddies Quik Stop, which is located at 1524 W Elm Street. Ryan Johnson, 37, was found suffering from gunshot wounds, a report said.<br /> He was treated at the scene and transported to a local hospital, where Johnson died. Huber fled the scene but was located a day later at a residence and was arrested.<br /> Oct. 6, 2018<br /> Donna LaForge, 65, of Oklahoma City was charged with first-degree manslaughter May 2, 2019.<br /> Yukon Police Department officers responded at about 10:05 a.m. Oct. 6, 2018 to an automobile versus pedestrian accident, a report read. An officer wrote that he observed a mountain bike under the front passenger side of a Ford F-150.<br /> The bicyclist, Leland Krich, 71, of Yukon, was transported to OU Medical, where he died as a result of injuries he suffered from the collision. One witness at the scene said LaForge’s pickup was stopped at the stop sign near 3rd Street and Poplar Avenue, while another said she rolled through it.<br /> LaForge told officers she never saw Krich as she pulled away from the sign. She said she felt the impact of hitting something and exited her truck to see what she hit.<br /> The report said LaForge stated she couldn’t remember if she had fully stopped at the sign or if she rolled it. Officers asked her if she was distracted by anything inside or outside of her vehicle, causing her to not see Krich on his bike.<br /> She said she must have been watching people on 3rd Street.<br /> After a blood test, it was confirmed LaForge was under the influence of marijuana, as well as meth, ecstasy and amphetamine. She also admitted to using marijuana frequently and had used the drug at about 8 p.m. the day before the collision, according to an affidavit.<br /> After investigators reconstructed the collision, they determined Krich would have been well into the intersection to establish control, requiring LaForge to yield right of way to him. They also confirmed if LaForge had in fact rolled the stop sign, the time of Krich’s travel would have placed him farther into the intersection and closer to impact. In this event, the bicyclist would have established even more control, according to the affidavit.</p> <p>Nov. 10, 2018</p> <p>Chance Girten, 25, of Clayton was charged Jan. 18, 2019 with first-degree manslaughter.<br /> Oklahoma Highway Patrol troopers responded at about 2 a.m. Nov. 10, 2018 to a fatal collision on Cedar Road near SW 15th Street. A Dodge Ram driven by Girten was traveling northbound on Cedar Road from Lyanna’s Lakeside Bar &amp; Grill.<br /> Girten’s passenger was Byan Flores, 34, of Kellyville. While traveling northbound on Cedar Road, Girten failed to negotiate a left-hand curve, an affidavit read.<br /> He departed the roadway to the right, striking multiple trees and a fence before coming to a rest below a curve in the roadway in an agricultural field.<br /> Flores died from the impact with the large trees and deceleration of the vehicle that was traveling at a high rate of speed, troopers reported.<br /> Troopers said they learned Girten and Flores left work Nov. 9, 2018 to eat at a restaurant and then later spend the remainder of the night at the bar, where Girten consumed a reportedly large amount of alcohol. Girten was traveling approximately 100 miles per hour when he left the roadway.<br /> His blood alcohol content was also 0.22 when he arrived at an area hospital, the affidavit stated.</p> <p>Dec. 24, 2018</p> <p>Jeffrey Glidewell, 41, of Mustang was charged with negligent homicide Oct. 14, 2019.<br /> Glidewell was traveling westbound on SW 59th Street, approaching Mustang Road at about 10:59 a.m. Dec. 24, 2018. Chester Boevers, 69, of Oklahoma City and his passenger, Dorothy Boevers, 92, were traveling eastbound on SW 59th Street from Mustang Road.<br /> Glidewell told officers he was digging around in his truck to find a receipt, and when he looked up, a vehicle in front of him was stopping to turn left into a neighborhood, a report read. To avoid hitting the vehicle, Glidewell said he swerved left.<br /> Whenever he swerved, Glidewell traveled left of the center of the road, hitting the Boevers head on. The Boevers were transported to OU Medical.<br /> Dorothy Boever was admitted to the intensive care unit. She later died on Christmas Day of 2018 as a result of the injuries she suffered in the collision.<br /> Glidewell initially told officers he swerved to avoid hitting an animal but could not describe the mammal. Three witnesses told officers they never saw an animal.<br /> When officers told Glidewell what witnesses said, he changed his story, the report read. Glidewell said he had been on his phone, paying his bills prior to the collision but not during.<br /> He said he never saw the Boevers’ vehicle because he was looking for a receipt.<br /> The collision report found there was no improper action taken by the Boevers.</p> <p>March 21, 2019</p> <p>Ramon Hector Martinie-Ontiveros, 36, was charged with second-degree murder May 16, 2019.<br /> At about 7:15 p.m. March 21, 2019, officers with the Canadian County Sheriff’s Office were dispatched to an area off State Highway 37 in Hinton in regard to a gunshot victim, an initial police report read. Hinton Police Department officers were on scene when the sheriffs arrived.<br /> Officers had secured an SUV and trailer with crime scene tape. Two occupants of the vehicle were sitting on the ground, and another person was being treated in an ambulance.<br /> The initial crime scene was reported to have taken place at State Highway 37 and south Karns Road on a dead end. Sheriffs located witness Tommy Alvarez, 36, at the initial scene.<br /> As officers detained Alvarez, he told them there was a gun in the grass near them. An AR-15, which was encased in Saran wrap, was located.<br /> There was also shattered glass, four bullet casings and a back windshield wiper blade in the road.<br /> After investigators arrived on scene about an hour later, it was confirmed Paige Gomer, 28, of Hinton was shot by Ontiveros, according to an affidavit.<br /> Gomer died of a gunshot wound to the chest, according to an autopsy report. A toxicology report also indicated there was meth and amphetamine in Gomer’s blood.<br /> Two witnesses informed an investigator that they saw Ontiveros fire a rifle inside the vehicle German Zamarripa, 31, was driving.<br /> Gomer was in the passenger seat of the vehicle. The witnesses also said Ontiveros was upset with Zamarripa over insults he made about Ontiveros’ wife.<br /> After Ontiveros stopped firing at the vehicle, he handed the weapon to Alvarez, who laid it on the ground, a probable cause affidavit read.<br /> Once investigators completed their search of the vehicle, they found four casings. There was also an entry and exit bullet hole where Gomer was in the front passenger seat.<br /> Included in the affidavit was also Ontiveros’ inquiry to a deputy during his transport to the sheriff’s office. Ontiveros asked the officer if he hurt anyone.<br /> The deputy recorded the statement on his work phone and did not question Ontiveros.<br /> Gomer died at 8:30 p.m. March 21, 2019 at an area hospital.</p> <p>Oct. 26, 2019</p> <p>Tristan Gaskey, 25, of Stillwater was charged with first-degree manslaughter April 1, 2020.<br /> Gaskey was traveling southbound on the Kilpatrick Turnpike’s southbound exit ramp, approaching State Highway 66 at about 1:30 a.m. Oct. 26, 2019. Craig Caldwell, 58, of Midwest City was traveling eastbound in the left lane on State Highway 66, approaching the Kilpatrick Turnpike’s southbound ramps.<br /> A witness told officers that Gaskey went through a red light, a collision report stated. The front left of Caldwell’s vehicle collided with Gaskey’s right side.<br /> Gaskey’s vehicle traveled southeast through a ditch and rested atop a hill. Caldwell also traveled to the southeast, his driver’s side colliding with a signal light pole.<br /> His vehicle caught on fire.<br /> The collision report found that there was no improper action on Caldwell’s behalf.</p> <p>March 21, 2020</p> <p>Anil Azmat, 34, of Oklahoma City was charged with first-degree murder, child abuse Sept. 11, 2020.<br /> Oklahoma City officers responded at about 9:16 a.m. March 21, 2020 regarding a 3-month-old, Amora Azmat, who wasn’t breathing at a property in the city. Officers spoke with Anil Azmat, the parent of Amora, and Taylor Tambunga, 22, of Oklahoma City, the infant’s other parent, while first responders performed CPR on Amora.<br /> The baby was then transported to OU Medical. She later died at the hospital.</p> <div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_32 addtoany_list" data-a2a-url="https://www.theyukonreview.com/2021/03/22/county-ada-says-pending-homicides-high/" data-a2a-title="County ADA says pending homicides high"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fwww.theyukonreview.com%2F2021%2F03%2F22%2Fcounty-ada-says-pending-homicides-high%2F&amp;linkname=County%20ADA%20says%20pending%20homicides%20high" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fwww.theyukonreview.com%2F2021%2F03%2F22%2Fcounty-ada-says-pending-homicides-high%2F&amp;linkname=County%20ADA%20says%20pending%20homicides%20high" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div> </div> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags">Posted in <a href="https://www.theyukonreview.com/category/breaking-news/" rel="category tag">Breaking News</a>, <a href="https://www.theyukonreview.com/category/canadian-county/" rel="category tag">Canadian County</a>, <a href="https://www.theyukonreview.com/category/news/" rel="category tag">Yukon News</a>, <a href="https://www.theyukonreview.com/category/yukon-review-breaking-news/" rel="category tag">Yukon Review Breaking News</a></div></div> <div class="fl-comments"> <div id="respond"> <h3 class="fl-comments-respond-title">Leave a Comment</h3> <form class="fl-comment-form" action="https://www.theyukonreview.com/wp-comments-post.php" method="post"> <label for="author">Name (required)</label> <input type="text" name="author" class="form-control" value="" tabindex="1" aria-required='true' /> <br/> <label for="email">Email (will not be published) (required)</label> <input type="text" name="email" class="form-control" value="" tabindex="2" aria-required='true' /> <br/> <label for="comment">Comment</label> <textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea> <br/> <div class="g-recaptcha" data-sitekey="6LdvRcMZAAAAAEXIplzSR6ZvSkSZTV1inA8BbwkV"></div> <br> <input name="submit" type="submit" class="btn btn-primary" tabindex="5" value="Submit Comment"/> <input type='hidden' name='comment_post_ID' value='307974' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /> <div class="fl-comment-form-cancel"> <a rel="nofollow" id="cancel-comment-reply-link" href="/2021/03/22/county-ada-says-pending-homicides-high/#respond" style="display:none;">Click here to cancel reply.</a> </div> </form> </div> </div> <style>
                    .fl-post-featured-post {
                        border-bottom: 1px solid #e6e6e6;
                        margin-bottom: 10px;
                        padding-bottom: 0px;
                        margin-left: 20px;
                    }

                    .fl-post-featured-image-beside .fl-post-featured-image {
                        float: left;
                        width: 120px;
                        padding-right: 5px;
                    }

                    .fl-clear {
                        clear: both;
                    }

                    h5.fl-post-featured-title {
                        margin: 0 0 10px;
                        padding: 0;
                        font-weight: bold;
                    }

                    .fl-post-featured-image {
                        margin-bottom: 10px;
                    }

                    .fl-post-featured-image img {
                        height: auto !important;
                        width: 100% !important;
                    }

                    .fl-post-featured-header {
                        margin-bottom: 15px;
                    }

                </style> <div id="webads-related-posts"> <h3>Related Posts</h3> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.theyukonreview.com/2021/03/18/training-held-for-veterans-service-dogs/" rel="bookmark" title="Training held for veterans, service dogs"> <img width="300" height="300" src="https://www.theyukonreview.com/wp-content/uploads/2021/03/service-dog-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.theyukonreview.com/2021/03/18/training-held-for-veterans-service-dogs/" rel="bookmark" title="Training held for veterans, service dogs">Training held for veterans, service dogs</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.theyukonreview.com/2021/03/18/training-held-for-veterans-service-dogs/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.theyukonreview.com/2021/03/18/canadian-county-camp-hope-to-serve-children-teens-exposed-to-domestic-violence/" rel="bookmark" title="Canadian County Camp HOPE to serve children, teens exposed to domestic violence"> <img width="300" height="300" src="https://www.theyukonreview.com/wp-content/uploads/2021/03/Camp-HOPE-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" srcset="https://www.theyukonreview.com/wp-content/uploads/2021/03/Camp-HOPE-300x300.jpg 300w, https://www.theyukonreview.com/wp-content/uploads/2021/03/Camp-HOPE-1024x1024.jpg 1024w, https://www.theyukonreview.com/wp-content/uploads/2021/03/Camp-HOPE-768x768.jpg 768w, https://www.theyukonreview.com/wp-content/uploads/2021/03/Camp-HOPE.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.theyukonreview.com/2021/03/18/canadian-county-camp-hope-to-serve-children-teens-exposed-to-domestic-violence/" rel="bookmark" title="Canadian County Camp HOPE to serve children, teens exposed to domestic violence">Canadian County Camp HOPE to serve children, teens exposed to domestic violence</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 18, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.theyukonreview.com/2021/03/18/canadian-county-camp-hope-to-serve-children-teens-exposed-to-domestic-violence/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.theyukonreview.com/2021/03/11/307961/" rel="bookmark" title="Oklahoman details life without traditional shelter"> <img width="300" height="300" src="https://www.theyukonreview.com/wp-content/uploads/2021/03/Eaton2-2-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.theyukonreview.com/2021/03/11/307961/" rel="bookmark" title="Oklahoman details life without traditional shelter">Oklahoman details life without traditional shelter</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 11, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.theyukonreview.com/2021/03/11/307961/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.theyukonreview.com/2021/03/10/mhs-to-return-to-classrooms-fulltime/" rel="bookmark" title="MHS to return to classrooms fulltime"> <img width="300" height="300" src="https://www.theyukonreview.com/wp-content/uploads/2020/09/Mustang-Broncos-logo-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" srcset="https://www.theyukonreview.com/wp-content/uploads/2020/09/Mustang-Broncos-logo-300x300.jpg 300w, https://www.theyukonreview.com/wp-content/uploads/2020/09/Mustang-Broncos-logo-768x768.jpg 768w, https://www.theyukonreview.com/wp-content/uploads/2020/09/Mustang-Broncos-logo-1024x1024.jpg 1024w, https://www.theyukonreview.com/wp-content/uploads/2020/09/Mustang-Broncos-logo.jpg 1200w" sizes="(max-width: 300px) 100vw, 300px" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.theyukonreview.com/2021/03/10/mhs-to-return-to-classrooms-fulltime/" rel="bookmark" title="MHS to return to classrooms fulltime">MHS to return to classrooms fulltime</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 10, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.theyukonreview.com/2021/03/10/mhs-to-return-to-classrooms-fulltime/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> <div class="fl-post-featured-post fl-post-featured-image-beside fl-post-featured-has-image" itemscope="itemscope" itemtype="http://schema.org/BlogPosting"> <div class="fl-post-featured-image"> <a href="https://www.theyukonreview.com/2021/03/10/mustang-officers-undergo-mental-health-training/" rel="bookmark" title="Mustang officers undergo mental health training"> <img width="300" height="300" src="https://www.theyukonreview.com/wp-content/uploads/2021/03/MPD-training-3-300x300.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" loading="lazy" itemprop="image" /> </a> </div> <div class="fl-post-featured-header"> <h5 class="fl-post-featured-title" itemprop="headline"> <a href="https://www.theyukonreview.com/2021/03/10/mustang-officers-undergo-mental-health-training/" rel="bookmark" title="Mustang officers undergo mental health training">Mustang officers undergo mental health training</a> </h5> <div class="fl-post-featured-meta"> <span class="fl-post-featured-date"> March 10, 2021 </span> <span class="fl-sep"> | </span> <span class="fl-post-featured-comments"> <a href="https://www.theyukonreview.com/2021/03/10/mustang-officers-undergo-mental-health-training/#respond">No Comments »</a></span> </div> </div> <div class="fl-clear"></div> </div> </div> </article> </div> <div class="fl-sidebar fl-sidebar-right fl-sidebar-display-always col-md-3" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"> <aside id="adrotate_widgets-2" class="fl-widget widget_adrotate_widgets"><h4 class="fl-widget-title">Business Spotlight</h4><div class="g g-1"><div class="g-dyn a-3 c-1"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Employment Site Ad', 1.00, {'nonInteraction': 1});" href="http://www.hometownemploymentnetwork.com/default.aspx?affiliateid=1105" target="_blank"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Employment Site Ad', 2.00, {'nonInteraction': 1});" src="https://www.theyukonreview.com/wp-content/uploads/2016/05/15912.jpg" /></a></div></div></aside><aside id="adrotate_widgets-3" class="fl-widget widget_adrotate_widgets"><div class="a-single a-10"><a onClick="ga('send', 'event', 'Adverts', 'click', 'Breaking News Signup', 1.00, {'nonInteraction': 1});" href="https://www.theyukonreview.com/breaking-news-signup/"><img onload="ga('send', 'event', 'Adverts', 'impression', 'Breaking News Signup', 2.00, {'nonInteraction': 1});" src="https://www.theyukonreview.com/wp-content/uploads/2016/04/breakingNewsHeader.png" /></a></div></aside><aside id="webads_displayads_widget-2" class="fl-widget widget_webads_displayads_widget"> <style>
                    #displayAds img {
                        width: 100%;
                        height: auto;
                    }

                                        #displayAdsWrapper {
                        height: 1500px;
                        overflow: hidden;
                    }
                    

                </style> <div id="displayAdsWrapper"> <div id="displayAds"> <ul id="displayAdsUL"> </ul> </div> </div>  </aside> </div> </div> </div> </div> </div> <footer class="fl-page-footer-wrap" itemscope="itemscope" itemtype="http://schema.org/WPFooter"> <div class="fl-page-footer-widgets"> <div class="fl-page-footer-widgets-container container"> <div class="fl-page-footer-widgets-row row"> <div class="col-sm-6 col-md-6"><aside id="nav_menu-3" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Yukon Review</h4><div class="menu-footer-menu-1-container"><ul id="menu-footer-menu-1" class="menu"><li id="menu-item-8667" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8667"><a href="https://www.theyukonreview.com/yukon-review/">Yukon Review Homepage</a></li> <li id="menu-item-230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-230"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff">Yukon Review E-Edition</a></li> <li id="menu-item-8664" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8664"><a href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=4c3c92d5-24cd-4721-b658-6f1dc23a4cff&#038;view=archives">Yukon Review Archives</a></li> <li id="menu-item-229" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-229"><a href="https://www.theyukonreview.com/contact-us/">Contact Yukon Review</a></li> <li id="menu-item-8726" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8726"><a href="https://www.theyukonreview.com/photos/">Photos</a></li> <li id="menu-item-8724" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8724"><a href="https://www.theyukonreview.com/crossword/">Crossword Puzzle</a></li> </ul></div></aside></div><div class="col-sm-6 col-md-6"><aside id="nav_menu-4" class="fl-widget widget_nav_menu"><h4 class="fl-widget-title">Mustang News</h4><div class="menu-footer-menu-2-container"><ul id="menu-footer-menu-2" class="menu"><li id="menu-item-8666" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8666"><a href="https://www.theyukonreview.com/mustang-news/">Mustang News Homepage</a></li> <li id="menu-item-8662" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8662"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24">Mustang News E-Edition</a></li> <li id="menu-item-8663" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8663"><a target="_blank" rel="noopener noreferrer" href="http://1336.newstogo.us/editionviewer/default.aspx?Publication=bce1911d-ddcd-4c61-81d1-15bdac417b24&#038;view=archives">Mustang News Archives</a></li> <li id="menu-item-8665" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8665"><a href="https://www.theyukonreview.com/contact-mustang-news/">Contact Mustang News</a></li> <li id="menu-item-8731" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8731"><a href="https://www.theyukonreview.com/photos/">Photos</a></li> <li id="menu-item-8729" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8729"><a href="https://www.theyukonreview.com/crossword/">Crossword Puzzle</a></li> </ul></div></aside></div> </div> </div> </div><div class="fl-page-footer"> <div class="fl-page-footer-container container"> <div class="fl-page-footer-row row"> <div class="col-md-12 text-center clearfix"><div class="fl-page-footer-text fl-page-footer-text-1">This website is powered by <a href="http://www.websitesfornewspapers.com" target="_blank"><i><strong>WebsitesForNewspapers.com</strong></i></a></div></div> </div> </div> </div> </footer>            
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script></body></html>
<!--
Cached page generated by Borlabs Cache - more information https://borlabs.io/
Time to create cache: 2.68557787 sec
Time to load cache: 0.36993814
Cache file created on: 2021-03-22T20:01:46+00:00
Current time: 2021-03-22T20:50:33+00:00
-->